Wacom Pen Partner

[yaro][~]$ uname -r
2.6.17-10-386
[yaro][~]$

najpierw:


sudo apt-get install xserver-xorg-input-wacom wacom-tools

a teraz polecenie:


sudo wacdump /dev/input/wacom

Wyswietlilo mi takie informacje:


MODEL=Wacom PenStation ROM=1.4-2
CLS=USB VNDR=Wacom DEV=Volito2 SUB=FT-0203-U

Wchodzimy na


http://linuxwacom.sourceforge.net/index.php/dl

i sciagamy najnowsza wersje, rozpakowujemy, wlazimy do katalogu.


i wykonujemy


./configure --enable-wacom

powinno sie pokazac na koncu w ktorejs z linijek:



wacom.o yes

teraz przeszedlem do najbardziej pasujacego dla mnie katalogu, czyli:


cd /tmp/linuxwacom-0.7.6-4/src/2.6.16/

i wykonalem


make

z jakiegos powodu nie ma katalogu dla kernela 2.6.17, kompilacja w .18 sie wysypywala, ale w 16 wszystko poszlo dobrze.



w wyniku dostalem driver:


[yaro][/tmp/linuxwacom-0.7.6-4/src/2.6.16]$ ls |grep .ko
-rw-r--r-- 1 yaro disk 24353 2006-12-07 21:05 wacom.ko
[yaro][/tmp/linuxwacom-0.7.6-4/src/2.6.16]$

teraz podmienimy stary dupny driver na nasz nowy.


[yaro][/tmp/linuxwacom-0.7.6-4/src/2.6.16]$ cd /lib/modules/`uname -r`/kernel/drivers/usb/input
[yaro][/lib/modules/2.6.17-10-386/kernel/drivers/usb/input]$ sudo cp wacom.ko wacom.ko_backup
Password:
[yaro][/lib/modules/2.6.17-10-386/kernel/drivers/usb/input]$ sudo cp /tmp/linuxwacom-0.7.6-4/src/2.6.16/wacom.ko .
[yaro][/lib/modules/2.6.17-10-386/kernel/drivers/usb/input]$ ls -l|grep wac
-rw-r--r-- 1 root root 24353 2006-12-07 21:08 wacom.ko
-rw-r--r-- 1 root root 24353 2006-12-07 21:08 wacom.ko_backup
[yaro][/lib/modules/2.6.17-10-386/kernel/drivers/usb/input]$

teraz wyladuj stary driver poleceniem:


sudo rmmod wacom

i zaladuj nowy


sudo modprobe wacom

do /etc/X11/xorg.conf w dowolnym miejscu dopisz nastepujace sekcje (jesli juz tam jakies podobne sa usun je):


Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "USB" "on"
Option "Vendor" "WACOM"
EndSection
Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "USB" "on"
Option "Vendor" "WACOM"
EndSection
Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "USB" "on"
Option "Vendor" "WACOM"
EndSection

a do sekcji ServerLayout dopisz linijki


InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"

tak aby wygladalo to mniej-wiecej tak jak u mnie:


Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
Option "StandbyTime" "2" # Turn off screen in 2 minutes
Option "SuspendTime" "3"
Option "OffTime" "4"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

wyloguj sie z X'ow, zrestartuj dm (kdm lub gdm - zaleznie co uzywasz) przez nacisniecie ctrl+alt+backspace i w tym momencie tablet powinien juz dzialac...

Comments